
Zelf aan de slag  

Nu is het tijd om zelf aan de slag te gaan. Hiervoor hebben we een simpele masterclass-
omgeving gebouwd, deze gaan we nu eerst bekijken. Ga naar 

 
Zoals je ziet is de omgeving vrij leeg en simpel. Dit is om je genoeg ruimte tot uitbreiding te 
geven en om de tijd die de computer nodig heeft om de omgeving na aanpassingen opnieuw te 
berekenen klein te houden. (De tijd die het compilen nodig heeft, hiermee kom je in aanraking 
zodra je met de editor van Half-Life 2 aan de slag gaat.) 
Wat je nu als eerst gaat doen is het aanpassen van textures, oftewel, de afbeeldingen die op de 
oppervlakken van de objecten in de omgeving zitten. Voor we hiermee aan de slag gaan eerst 
een kleine uitleg over het soort afbeeldingen dat Half-Life 2 voor textures gebruikt.   

Het converteren van textures 

Half-Life 2 en de Mods hiervan gebruiken een speciaal formaat om textures op te slaan. Voor 
elke texture zijn er twee bestanden nodig: het .vtf bestand en het .vmt bestand. Het 
eerstgenoemde is de texture zelf en het laatstgenoemde is een tekstbestandje waarin onder 
andere staat beschreven wat het voor texture is en waar het zich bevindt. 

Het is mogelijk om een willekeurig .jpg plaatje om te zetten naar het vtf bestand. Er is echter 
één voorwaarde: de plaatjes moeten 128 pixels x 128 pixels, 256 pixels x 256 pixels of 512 
pixel x 512 pixels zijn. Houd hier rekening mee voordat je begint met converteren. 

Voor de conversie maak je gebruik van VTFEdit. Dit programma is te vinden op de volgende 
locatie: . 
Je kan je eigen jpg file laden door op File -> Import te klikken. Nadat je het plaatje hebt 
geselecteerd krijg je een optie scherm. Klik hier gewoon op OK. Het .vtf bestand kan dan 
gegenereerd worden door naar File -> Save te gaan. Het andere bestand (.vmt) kan je 
genereren door te gaan naar Tools -> Create VMT file. Onder het tabblad "options" kan je bij 
"Surface 1" ook nog aangeven hoe de texture zich moet gedragen (bijvoorbeeld als metaal). 
Druk op create en selecteer de locatie en naam.  

Samenvatting: 

o Zorg dat je plaatje van het juiste formaat is (128x128, 256x256 of 512x512).  
o Start VTFEdit.exe uit map D:\VTFEdit.  
o File -> Import en selecteer je jpg file.  
o Druk op OK bij option scherm.  
o File -> Save As om .vtf te genereren.  
o Tools -> Create VMT file om .vmt te genereren.  
o Geef onder Surface 1 in tabblad options het gedrag van de texture aan.  
o Druk op create.  

Textures aanpassen in de masterclass-omgeving  

Nu je de masterclass-omgeving hebt gezien en weet hoe je textures kunt converteren is het tijd 
om daadwerkelijke textures te gaan aanpassen. In de omgeving heb je verschillende objecten 
gezien die elk een texture hebben. Door nieuwe textures onder dezelfde naam op te slaan 



zullen deze in het spel vervangen worden. De volgende textures zijn aanpasbaar in het spel 
door nieuwe textures op te slaan onder de volgende namen:  

 
bord_boven 

 
bord_onder 

 
poster1 

 
poster2 

 
poster3 

 

raam  

Probeer een aantal textures te vervangen en start het spel om het resultaat te kunnen zien. 
Gebruik de afbeeldingen die je meegenomen hebt of zoek nieuwe afbeeldingen op internet. 
Als je klaar bent met het vervangen van textures of er genoeg van hebt kun je verder gaan met 
de volgende opdracht.   

Hammer opstarten 

We gaan nu aan de slag met de editor van Half-Life 2, Hammer. Om Hammer op te starten 
moet je het volgende doen: 

 

Dubbelklik op het Steam icoontje rechtsonder in de taakbalk. Je krijgt nu 3 tabbladen 
te zien: Store, Games en Tools. 

 

Onder Tools staat Source SDK. Dubbelklik hierop om het te starten. Na wat geduld te 
hebben gehad krijg je het Source SDK scherm.  

 

Bovenaan het Source SDK scherm zie je Applications staan met daar meteen onder 
Hammer Editor. Dubbelklik hierop om de editor te starten. Na nog wat geduld te 
hebben gehad kom je in de editor. 

Werken in Hammer 

Om aan de slag te kunnen met de testmap zul je deze eerst moeten openen. Ga naar File, 
Open en open dan de testmap, die te vinden is in: .  

Nu iets over de lay-out van Hammer: Links vind je een balk met icoontjes die de 
basisfunctionaliteiten van de editor bevatten. In het midden heb je vier vensters: linksboven 
het camerabeeld, daarin zou je al iets van de omgeving moeten kunnen herkennen. 
Rechtsboven een bovenaanzicht, linksonder een vooraanzicht en rechtsonder een zijaanzicht. 
In de verschillende aanzichten kun je de balken aan de zij- en onderkant en de pijltjestoetsen 
gebruiken om het beeld te verschuiven en het scrollwieltje om in- of uit te zoomen. In het 
camerabeeld kun je de camera verplaatsen met W, A, S en D en draaien met de pijltjestoetsen. 
De muis heeft dezelfde functionaliteit als de pijltjes toetsen nadat je Z ingedrukt hebt. (Plaats 
de cursor altijd in het venster waarin je wilt bewegen.) Probeer het even uit om aan de 
besturing te wennen. Als je opeens een blauw vierkant met skybox ziet in een zwarte 
omgeving ben je buiten de rand van de omgeving gegaan, beweeg dan weer door de skybox 
heen naar binnen en je zult de omgeving weer zien.  

Iets anders wat belangrijk is, is het aanpassen van het rooster van de 2D-aanzichten. Het 
verslepen en uitrekken van objecten past zich aan dit rooster aan. Voor detailwerk zal dus een 
klein rooster nodig zijn terwijl voor het recht naast elkaar zetten van grote objecten een groter 



rooster handig is. Het rooster kan je verkleinen met [ en vergroten met ]. Probeer het maar uit. 
Als je het rooster te klein maakt kan het zijn dat het opeens weer groter lijkt te worden. De 
hokjes zijn dan te klein om weer te geven, zoom in met het scrollwiel en je zult zien dat het 
rooster wel degelijk verkleint is.  

Dit is alles wat je moet weten om in Hammer aan de slag te kunnen.  

Een object maken  

Nu Hammer geopend is en je kunt rondkijken in de verschillende aanzichten kun je een 
simpel object gaan maken, laten we beginnen met een eenvoudig bankje. Begin door links in 
beeld op de Block Tool te klikken (het witte kubusje). Rechts in beeld verschijnt vervolgens 
een lijst waarin je onder Object verschillende basisobjecten kunt selecteren. Standaard staat 
deze op block en dit is goed. Klik vervolgens ergens in het bovenaanzicht en sleep de muis, je 
ziet nu een vierkantje ontstaan. Maak een vierkantje van 1 roosterblokje groot. Je ziet nu 
maten verschijnen bij de zijden van het blokje, zoals 32.0 of 128.0. We beginnen met het 
maken van de poten van het bankje (2 betonnen blokken, daarop komen dan een stel houten 
planken). Een goede afmeting voor zo n poot is 24 bij 8 met een hoogte van 24. 
Waarschijnlijk moet je het rooster verkleinen om deze grootte te kunnen maken, gebruik hier [ 
en ] voor. Verklein het rooster en versleep vervolgens één van de hoekpunten van het vierkant 
om deze grootte aan te passen. Waarschijnlijk zul je ook even in moeten zoomen met behulp 
van het scrollwiel. Herhaal dit proces tot je in het bovenaanzicht de afmetingen 32 en 8 hebt. 
(In welke richtingen maakt niet zoveel uit, het bankje kan verschillende kanten op gedraaid 
zijn.) 
Nu moet de hoogte nog aangepast worden. Gebruik hiervoor het voor- of zijaanzicht. Een 
hoogte van 24 moet goed zijn. Ook zal het bankje op de goede hoogte moeten worden 
geplaatst. Doe dit door in het midden te klikken van het blokje en het vervolgens omhoog of 
omlaag te slepen. Zorg dat de onderkant op dezelfde lijn staat als het poppetje met 
info_player_start boven zijn hoofd. Je kunt de hoogte ook controleren in het camerabeeld. 
Nu het blok de juiste vorm heeft is het tijd om het van een stel stippellijntjes te veranderen in 
een daadwerkelijk object. Klik met je rechtermuisknop op het vierkantje in één van de 2D-
aanzichten en vervolgens op Create Object. De lijntjes worden nu rood en in het camerabeeld 
zie je een echt object verschijnen met een rode gloed. Dit geeft aan dat het object geselecteerd 
is.  

Door deze gloed is dezelfde texture als die van de grond te zien, baksteen. Dit is natuurlijk 
niet de bedoeling en daarom gaan we dit nu veranderen.  
Rechts in beeld zie je een afbeelding van de texture met een knop Browse ernaast. Klik 
hierop en er verschijnt een enorme lijst met textures waar je in kunt zoeken. Om je dit zoeken 
te besparen heeft Hammer een aantal handige opties. Type concrete achter Filter en de lijst 
wordt beperkt tot alleen textures met concrete in de naam. Gebruik de balk rechts om door 
de texturese te scrollen, het scrollwiel werkt niet en kan ervoor zorgen dat het veld achter 
Filter weer leeg raakt. Zoek een passende betonnen texture voor de poten en dubbelklik 
vervolgens op deze afbeelding, waarna het venster weer sluit. Rechts zie je nu de nieuwe 
texture afgebeeld. 
Om deze texture aan het object te geven moet nog één ding gebeuren. Zorg eerst dat het blok 
geselecteerd is. Doe dit door eerst linksboven op de Selection Tool te klikken (het pijltje, het 
bovensten icoontje) en vervolgens op het blok, wat nu rood-geel gestreept is in de 2D-
aanzichten en ook weer de vierkantjes aan de rand heeft, waarmee je de maten eventueel nog 
aan kunt passen. Klik daarna links in beeld op Apply Current Texture (het kubusje van 



bakstenen). Dit geeft de huidige texture aan de geselecteerde objecten, je kunt dit ook zien 
veranderen.  

Nu moet er een tweede poot gemaakt worden, dit zou natuurlijk kunnen door het hele proces 
weer te herhalen, maar gelukkig is er een makkelijkere manier voor. Je kunt een object 
kopiëren door Shift ingedrukt te houden en vervolgens het object te verslepen. Plaats het 
tweede blok op een afstand die je goed lijkt voor een bankje.  

Nu het zitvlak nog. Maak hiervoor een blok op dezelfde manier als je met de eerste poot 
gedaan hebt. Maak het 2 hoog, zorg dat het bovenop de poten komt te staan en zorg dat het 
naar de zijkanten 2 uitsteekt. Pas vervolgens weer de texture aan door ditmaal op wood  te 
filteren. Niet alle textures hiervan zijn even geschikt, woodwall009a geeft wel een mooi 
resultaat.  

Om het effect te kunnen zien zal de omgeving, in tegenstelling tot het aanpassen van textures, 
eerst gecompiled moeten worden. Druk op F9 en vervolgens op OK.   

Een model plaatsen  

Hammer bevat ook standaardobjecten, modellen genaamd, die je kant en klaar in je omgeving 
kunt plaatsen. 
Modellen kunnen geplaats worden met de Entity Creation Tool (boven het witte blokje). Klik 
hierop, zoek vervolgens rechts in beeld onder Objects de naam prop_physics op. Klik dan op 
een plaats in het camera beeld en er zal een rood blokje verschijnen. Klik op de Selection Tool 
(linksboven) en dubbelklik vervolgens op het blokje wat je net geplaatst hebt. Er verschijnt nu 
een nieuw venster met eigenschappen van het model. Ga naar World Model en klik op 
Browse  Er verschijnt weer een nieuw venster en in dit venster kan je een model kiezen. 
Linksboven vind je een lijst met mappen waarin modellen staan. Daaronder staat een lijst van 
modellen in de map die op dat moment geselecteerd is en rechtsboven kan je een voorbeeld 
van het model zien. (Je kan de camera hierin draaien om het model beter te kunnen bekijken.) 
Ga nu naar de map props_junk en zoek een model uit wat in de omgeving past. De meeste 
modellen in deze map kun je verschuiven of oppakken. (Je kunt dit controleren door 
rechtsonder op Info te klikken en kijken of physics aangevinkt is.) Klik nu op OK, dan op 
Apply in het andere venster en sluit vervolgens ook dit venster af. Verschuif het model zodat 
het op de grond komt te liggen/staan en druk weer op F9 en OK om het resultaat te bekijken.   

Een effect aanpassen  

In de spelomgeving staat een adresbord , zoals je deze op de VU aantreft. In ons klimaatspel 
waait dit bord omver in de storm. In deze omgeving blijft het bord zoals je waarschijnlijk al 

gemerkt zult hebben gewoon staan, daar gaat nu wat aan veranderen. 
Even een kleine uitleg van hoe het omvallen in zijn werk gaat: Om het bord zie je een geel 
doorzichtig blok met trigger op de grond. Dit is een proximity trigger die de nabijheid van 
de speler (maar ook van andere objecten) in de gaten houdt en vervolgens andere dingen kan 
activeren. Het bord zelf is een deur die open en dicht draaien (of algemener: kantelen) kan. 
Op dit moment is de proximity trigger inactief, waardoor er nog niks gebeurd is tijdens 
eerdere opdrachten. Om dit te veranderen moet je nu op de trigger dubbelklikken in het 
camerabeeld. Zoek vervolgens start disabled op in de lijst die verschijnt en verander dit van 



yes in no . Als je bovenaan op Outputs klikt kan je zien dat de trigger al verbonden is aan 
de deur. Klik op Apply om de veranderingen toe te passen en sluit daarna het venster. Doe een 
testrun en loop naar het adresbord toe om het effect te zien.  

Zoals je zult merken kloppen er een aantal dingen nog niet aan het effect. Het bord beweegt, 
maar de verkeerde kant op en het gaat ook erg langzaam. Er moeten dan ook twee dingen 
veranderen: 
De richting van de draaiing moet worden aangepast. Dubbelklik op het bord, er zal nu een 
zelfde soort venster verschijnen als bij de proximity trigger. Klik bovenaan op flags, hier 
staan een aantal opties dat je kunt aanvinken, waaronder X Axis en Y Axis. De deur draait 
standaard om de Z as, dat is de verticale as, zoals je ook van een deur zou verwachten. Nu is 
dit echter niet het geval, de bovenkant van het bord moet naar beneden, hiervoor moet X Axis 
worden aangevinkt. 
Ook de snelheid van de val moet worden aangepast. Ga terug naar Class Info, zoek Speed op 
in de lijst en verhoog de snelheid. Klik op Apply voor je het venster sluit en test het effect tot 
je tevreden bent over de snelheid.  

Iets waar je misschien nog niet tevreden over bent is dat de val wat onrealistisch lijkt omdat 
de deur met een constante snelheid beweegt. Probeer om de realiteit te vergroten een fiets 
tegen het bord te plaatsen, zodat het bord hier op valt. Doe dit door een model te plaatsen op 
de manier die je eerder gebruikt hebt. De fiets is te vinden onder props_junk. Je zult zien dat 
dit er een stuk beter uit ziet.   

Maak je eigen weerseffect  

Dit was de laatste van de serie opdrachten van de Masterclass. Je kunt nu proberen je eigen 
weerseffect te maken, de tutorials op de volgende pagina s kunnen je daarbij helpen. Dit 
effect kan dan vervolgens door ons in het klimaatspel worden geplaatst, waarna je het 
resultaat zelf kunt bekijken. Een andere optie is om deze omgeving uit te breiden door extra 
modellen toe te voegen of zelf meer objecten te maken. 
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